Query performance degraded in EU
Resolved·Degraded performance

We have released the fix and the mentioned queries are now scanning the expected amount of data.

Cluster load is back to normal and queries are responding as expected.

Mon, Oct 13, 2025, 08:24 PM
(1 month ago)
·
Affected components
Updates

Resolved

We have released the fix and the mentioned queries are now scanning the expected amount of data.

Cluster load is back to normal and queries are responding as expected.

Mon, Oct 13, 2025, 08:24 PM

Identified

We have applied some configurations to the cluster that have allowed to limit the load.

We are already testing the fix for the queries and will release it soon.

The cluster is more responsive now and load seems better, queries are responding better but there could still be some periods in which they are not as responsive.

Mon, Oct 13, 2025, 03:25 PM(4 hours earlier)

Identified

We have spotted an issue by which some queries are scanning way more data than they should and are making our cluster struggle with performance.

We are working on a fix.

Mon, Oct 13, 2025, 12:55 PM(2 hours earlier)