US: Routine Maintenance - event ingestion & destinations
Complete·Under maintenance·Oct 16, 12:00 PM - 2:00 PM

Everything is done, thanks for your patience!

Thu, Oct 16, 2025, 01:41 PM
(1 month ago)
·
Affected components
Event and Data Ingestion Lag
Destinations
Updates

Complete

Everything is done, thanks for your patience!

Thu, Oct 16, 2025, 01:41 PM

In progress

Maintenance work is done, we verified that the systems picked up data processing and all is well.

Delays in processing are going down. We are monitoring.

Thu, Oct 16, 2025, 01:01 PM(40 minutes earlier)

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Thu, Oct 16, 2025, 12:00 PM(1 hour earlier)

Scheduled

Maintenance will begin as scheduled in 60 minutes.

Thu, Oct 16, 2025, 11:00 AM(1 hour earlier)

Scheduled

We will perform a routine maintenance on PostHog Cloud US, which will delay event ingestion and destinations. No data will be lost during this operation.

Tue, Oct 14, 2025, 08:56 AM(2 days earlier)