Resolved
We realised that existing pods were rendered ineffective due to an internal issue that caused a steep increase in connections and repeated Redis timeout errors. We think the impact from the issue is over.
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.