Emails delayed due to a third-party processor incident
Degraded PerformanceJul 3, 2026·App (US Cloud 🇺🇸), App (EU Cloud 🇪🇺)
Resolved
Email deliverability is back to normal.
Fri, 3 Jul 2026, 11:30 UTC
Monitoring
Email queues are catching up and deliverability is coming to a nominal state. Monitoring.
Fri, 3 Jul 2026, 09:34 UTC(1 hour earlier)
Investigating
All emails are being delayed due to a third-party email provider undergoing an incident.
Emails will be received when the queue catches up, apologies for any inconvenience this may cause.
Fri, 3 Jul 2026, 09:04 UTC(2 hours earlier)