PostHogPostHog Status
Report a problem

Subscribe to updates

You'll receive emails for new incidents, as well as updates to existing incidents.

← Back to status

Logs ingestion: processing delays

Degraded Performance
Jul 16, 2026·Logs (EU Cloud 🇪🇺), Logs (EU Cloud 🇪🇺)

Resolved

EU log has has been stable

Fri, 17 Jul 2026, 13:13 UTC

Monitoring

logs ingestion lag is back to normal levels. we are continuing to monitor

Fri, 17 Jul 2026, 12:21 UTC(52 minutes earlier)

Investigating

We are still investigating the logs ingestion lag, no data loss has occurred.

Fri, 17 Jul 2026, 11:30 UTC(1 hour earlier)

Investigating

Logs ingestion in the EU is currently experiencing some lag, no data has been lost.

Fri, 17 Jul 2026, 09:48 UTC(3 hours earlier)

Resolved

Processing delays have cleared and we're back to normal operations at this time.

Thu, 16 Jul 2026, 21:13 UTC(16 hours earlier)

Monitoring

We have applied a fix and are seeing an improvement in processing delays. We will continue to monitor to ensure the issue is fully resolved.

Thu, 16 Jul 2026, 21:04 UTC(16 hours earlier)

Investigating

We’ve identified processing delays in the logs ingestion pipeline. Logs may take longer than usual to appear in the product. Data is not lost but may not show in PostHog apps and queries until the processing delay is resolved.

Thu, 16 Jul 2026, 20:33 UTC(16 hours earlier)

Logs ingestion: processing delays