MCP: elevated API error rates
Degraded PerformanceAug 20, 2026·MCP Server (EU Cloud 🇪🇺), MCP Server (US Cloud 🇺🇸)
Resolved
The MCP server operated normally throughout, and the elevated error rate was due to rate-limit responses to a few projects with unusually high request volume.
Thu, 20 Aug 2026, 16:55 UTC
Investigating
We’re investigating elevated MCP error rates impacting parts of the application.
Thu, 20 Aug 2026, 16:05 UTC(49 minutes earlier)