PostHogPostHog Status
Report a problem

Subscribe to updates

You'll receive emails for new incidents, as well as updates to existing incidents.

← Back to status

Analytics: query timeouts/failures

Aug 31, 2026

Resolved

Queries have returned to normal. We have identified the cause and are working on a fix to prevent the issue from occurring again.

Wed, 2 Sep 2026, 03:32 UTC

Monitoring

We've load-shed the traffic spikes and the latency has come down and the errors have decreased. Still investigating the potential culprits of the spike in the first place.

Tue, 1 Sep 2026, 04:02 UTC(23 hours earlier)

Investigating

We’ve identified an issue affecting analytics queries (timeouts and/or failures). Dashboards, insights, and other query-driven views may be slow or unavailable.

Mon, 31 Aug 2026, 23:57 UTC(1 day earlier)