Resolved
This incident has been resolved.
Monitoring
We've fixed the issue and are monitoring the results.
Investigating
This impacts our EU cloud only. We’ve identified processing delays in the event ingestion pipeline. Events may take longer than usual to appear in the product. Data is not lost but may not show in PostHog apps and queries until the processing delay is resolved.