Unplanned maintenance
Degraded PerformanceResolved
Security researchers alerted us to a potential issue which was patched. Out of an abundance of caution we rolled some credentials which caused temporary issues. These should now mostly been resolved.
Sat, 30 May 2026, 07:16
Identified
We are rotating keys after a security research team was able to confirm an exploit in one of our AWS environments. We're working with the security research team on the issue. No keys were publicly available, and no data has been compromised. You may see impacts on exports, reverse proxies, and other services. We'll have more updates as we continue to work on this incident.
Sat, 30 May 2026, 01:18(5 hours earlier)
Identified
We are currently performing unplanned maintenance, which may temporarily impact availability.
Sat, 30 May 2026, 01:03(6 hours earlier)